読者です 読者をやめる 読者になる 読者になる

dackdive's blog

新米webエンジニアによる技術ブログ。JavaScript(React), Salesforce, Python など

follow us in feedly

zc.buildoutでversion conflictエラーが出た時の対処法

Python zc.buildout

久しぶりに zc.buildout を使ったら以下のようなエラーが出た。

$ ./bin/buildout
Upgraded:
  setuptools version 8.2.1;
restarting.
Generated script '/Users/...(略).../bin/buildout'.
While:
  Installing.
  Getting section packages.
  Initializing section packages.
  Installing recipe appfy.recipe.gae.
Error: There is a version conflict.
We already have: setuptools 3.6
but zc.buildout 2.3.1 requires 'setuptools>=8.0'.

エラーで色々調べてみたけどもわからず。

解決法

単純に、エラーメッセージが示す通り setuptools のバージョンが古かったのが原因だったよう。

$ pip install -U setuptools

の後に再実行したらうまくいきました。